summaryrefslogtreecommitdiffstats
path: root/externals/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'externals/CMakeLists.txt')
-rw-r--r--externals/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/externals/CMakeLists.txt b/externals/CMakeLists.txt
index 64b48fd7b..6e5bfbba6 100644
--- a/externals/CMakeLists.txt
+++ b/externals/CMakeLists.txt
@@ -168,9 +168,13 @@ if (NOT TARGET LLVM::Demangle)
add_library(LLVM::Demangle ALIAS demangle)
endif()
-add_library(stb stb/stb_dxt.cpp stb/stb_image.cpp stb/stb_image_resize.cpp stb/stb_image_write.cpp)
+add_library(stb stb/stb_dxt.cpp)
target_include_directories(stb PUBLIC ./stb)
+if (NOT TARGET stb::headers)
+ add_library(stb::headers ALIAS stb)
+endif()
+
add_library(bc_decoder bc_decoder/bc_decoder.cpp)
target_include_directories(bc_decoder PUBLIC ./bc_decoder)